Results 1 to 9 of 9

Thread: Freezing in game

  1. #1

    USA Major

    Shiloh's Avatar
    Join Date
    Feb 2016
    Location
    Shepherdstown, WV
    Posts
    676

    Freezing in game

    Hello gents. I've been playing this fine game for over two years and close to 700 hours. No real issues to speak of until recently. I'm getting 'freezes' very often and in particular when fighting is close quarters and intense exchanges. Woods are particularly bad. The other night on a Harpers map I was freezing almost constantly over a 7-minute period of time and I could hear sounds but that's it.

    This has been occurring for months and I have not been able to remedy it. Here's what I've done to troubleshoot.

    - Upgraded my OS to Windows 10
    - Reinstalled the game about 10 times between two different SSD drives (one has OS the other doesn't)
    - Changed my NVIDIA settings to optimize performance
    - OC'd my CPU
    - Ran Windows memory Diagnostic to check ram (no errors found)
    - Re-seated all my ram
    - changed every possible setting under 'graphics' in War of Rights
    - Reinstalled Steam
    - Rolled back graphics drivers to before the time I was having issues
    - sacrificed a squirrel to the gaming gods

    I play Hell Let Loose, Rising Storm 2 on ultra... everything else runs perfectly but this game. Madden 2020 gives me a little bit of hiccups but generally every game I play is smooth as glass on max settings.

    Here's my rig.

    Windows 10
    i5-4670 CPU @ 3.4 GHz (OC'd to 3.8)
    GeForce GTX 1060 6GB
    Z87-GD-65 Gaming (MS-7845) mobo
    G.Skill Sniper Series Ram 16GB
    Corsair 650TX 650W ATX12V
    Dual monitors: LG 32" and Acer 24"
    Drives: 2 spinnies and 2 SSD

    One workaround I found the other night is when I'm freezing badly I hit ctrl>alt>del and don't quit out fully. This seems to reset WoR and I'm usually fine for a period of time after that. Any help is greatly appreciated.
    Last edited by Shiloh; 08-20-2019 at 02:41 PM.

  2. #2

    USA Major

    Shiloh's Avatar
    Join Date
    Feb 2016
    Location
    Shepherdstown, WV
    Posts
    676
    Quote Originally Posted by O'Rourke View Post
    Did you delete the shader cache folder for War of Rights under My Documents? This folder is not affected by deletions/reinstalls.


    I wonder if repeatedly pressing ALT+ENTER would have the same effect.

    1. Have you tried running the game in a borderless window?
    2. Have you tried enabling triple-buffering vsync?
    3. Have you tried changing heapsizes via launch parameters?

    Code:
    16GB: Launch command: -heapsize 2097152
    8GB: Launch command: -heapsize 1048576
    I don't have that folder in my documents. I went through and manually deleted all WoR folders before last install.

    1. I have briefly but not enough to test... it was awkward when I did check it out briefly as I'm so used to FS on everything.
    2. I just enabled TB
    3. I'll have to figure out how to do a launch command

  3. #3
    COL. Patrick R Cleburne's Avatar
    Join Date
    Apr 2019
    Location
    United States
    Posts
    46
    what are your in game sounds and other in game stuff like try turning your field of view to 80 and that might fix it for you

  4. #4
    COL. Patrick R Cleburne's Avatar
    Join Date
    Apr 2019
    Location
    United States
    Posts
    46
    you could have the best pc in the world but if your monitor is not up to pair then your will be limited by it more so than your pc

  5. #5
    COL. Patrick R Cleburne's Avatar
    Join Date
    Apr 2019
    Location
    United States
    Posts
    46
    i have spent over 1700 hrs in game and on 3 diffent set up over the last 10 almost 11 months you sound settings being turn up to high i have found makes alot of issues but not as much as haveing a bad ass pc and a cheap monitor or tv i now have a samsung 3D tv

  6. #6
    COL. Patrick R Cleburne's Avatar
    Join Date
    Apr 2019
    Location
    United States
    Posts
    46
    i used to think haveing your field of view was better to have lower for long range shooting but its actually not good

  7. #7
    Mark L. E. E. Smith's Avatar
    Join Date
    Jul 2017
    Location
    Manchester
    Posts
    48
    Janitor to aisle four please, janitor to aisle four.

  8. #8

    USA Major

    Shiloh's Avatar
    Join Date
    Feb 2016
    Location
    Shepherdstown, WV
    Posts
    676
    Thanks everyone for taking some time to help our. The triple-buffering may have been the setting to get me back in business. I'm not sure yet but I played for 30 minutes on Harpers with 140+ and no hitches at all. I appreciate it Ragtime!

    Quote Originally Posted by Mark L. E. E. Smith View Post
    Janitor to aisle four please, janitor to aisle four.

  9. #9

    Join Date
    May 2017
    Location
    Texas
    Posts
    3
    @Shiloh , Been having the same trouble. After enabling Triple Buffering in the Nvidia control panel for the Warofrights.exe, it seemed to workout fine for a while but I still ended up getting a long stutter. Not sure if your Ctrl+Alt+Del trick worked or not, but after the first stutter, I hit Ctrl+Alt+Del, went back into the game, and it ran smooth for another 10 minutes or so, until I exited the game.

    Will have to test it out later with bigger numbers. Was only 60 or so in that session. These long stutters are definitely frustrating, so it'd be nice to finally have a fix for it.

    I have a very similar PC build:
    Win 10 Pro
    i5 7600k 3.8ghz
    GTX 1060 6gb (Gigabyte)
    16gb G.skill ripjaws
    Last edited by Rook; 12-13-2019 at 05:28 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •